NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My daughter's 2003 VW NB 2.0l AVH showed a check engine light. Had the codes read at Autozone: P0101, P0171 (MAF sensor, lean bank one). I figured I'd run it home, clean the MAF.
Before I got home, it just shut down. Couldn't get it started, so towed it home, did some reading.
I let it sit and tried to start it again. It cranks, briefly starts, shuts down. Brake lights work. Can hear the fuel pump kick, it'll start (VERY briefly) at different revs depending on the gas pedal depression.
Now, I don't have a laptop or any VW software or any of that.
I'm scared to disconnect the battery to clear the codes, or even the MAF to clean it because some literature says I'd need to reset engine parameters with a scan tool if I do.
Any help?
Thanks,
divebri
 

·
Registered
Joined
·
2,231 Posts
Sudden stalling is usually caused by the engine speed sensor going bad.

If the engine runs normally for 1 second and shuts off it could be the immobilizer. With this the yellow "car with a key under it" light will be on as well. Try starting using a different key.

You can remove the MAF without disconnecting the battery. No problem there.

When disconnecting the battery you can do the reset yourself. Once the battery is reconnected just turn the key to "run" without starting the engine. Leave the key there for 30 seconds and then shut it off. This recalibrates the throttle body. You may need to reset things like the "auto-up" windows as well.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for info. Yeah, I tried another key- no go. If this was a different car (American, Japanese) I'd guess I've got a bad fuel pump. I don't know on this though. I've never messed with a VW before.
 
1 - 3 of 3 Posts
Top