VW Beetle Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, I'm a new New Beetle owner and just picked up a pretty nice 2000 for my daughter. Its a GL 2.0L with auto. No mods that I know of. Its got 90K and runs very well. Good history of dealer maintenance records. Smooth and powerful. Trouble is its only getting about 16-17 mpg (only 210 miles on the tank). When we got it, I changed the oil, oil filter, air filter and checked the plugs and plug wires, which are good. Also ran some STP injector cleaner through it. Now I'm pretty much stumped.

Any insight, suggestions or advice would be very much appreciated.
 

·
Bug me again!
Joined
·
2,758 Posts
try cleaning the MAF - cheap and easy to do with a can of CRC MAF cleaner
 

·
.
Joined
·
2,646 Posts
No check engine light (CEL)? Does the CEL come on when you first start the car? They have been known to burn out or be removed by unscrupulous types. Fuel filter, clean MAF, plugs, wires, air filter, change vacuum hoses and remedy any CELs are the best things to do. Some NBs had bad catalytic convertors--a partially plugged cat can play havoc with MPGs. Also, do you really know how the car is being driven?(sorry dad :eek: ) Short trips and jackrabbit starts could get you down here in MPGs... Low-mid 20's it what my wife gets in her 2.0L/auto Jetta.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top