NewBeetle.org Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Not sure where to post this, and if someone could guide me in the right direction that would be greatly appreciated.

We got this beetle with 90k miles on it... Ran fine for the first hour after purchase and then started shifting really hard. We took it back to the dealer, and they said they replaced a "Trans Control Module" it didn't fix ANYTHING. Does anyone know why the tranny does this??? Fluid level?
 

·
Registered
1964 Deluxe, 2005 GLS 2014 Rline
Joined
·
248 Posts
Trans control module? You mean the trans valve body? The 09G trans is plagued with issues with the valve body.
Changing the TCM won’t help
Valve body’s are about $600ish and it’s totally possible to DIY but if you bought from a dealer get them to fix it or don’t buy the car

Bit more info is needed, see if we can work out what’s wrong
 

·
5/23/10 <3
Joined
·
11,155 Posts
Did they scan the car for codes? I would get those code numbers to start with. Did you tell the dealer the issue still remained for them to fix it? Did you buy it from the dealer or private party?
 

·
Registered
Joined
·
871 Posts
Take it back, and get your money back. As pyro said 09G has issues and so does the 01M transmission (99.5-03), which were even worse. The 5 speed manual transmissions on the other hand were almost bullet proof.
 

·
Registered
Joined
·
1 Posts
Trans control module? You mean the trans valve body? The 09G trans is plagued with issues with the valve body.
Changing the TCM won’t help
Valve body’s are about $600ish and it’s totally possible to DIY but if you bought from a dealer get them to fix it or don’t buy the car

Bit more info is needed, see if we can work out what’s wrong
I wondered if that's the problem with mine...bought a '06 Beetle from private owner and she told me about the valve box...it rev's between 3rd and 4 th years...looking for a mechanic that works on foreign cars...it's drivable I would just like to get it fixed
 
1 - 5 of 5 Posts
Top