NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
So,I've got what appears to be the typical ignition switch/connector issue on my girlfriends 2007 Beetle.The symptoms are very typical with no headlights,no turn signals,A.C./blower fan and no wipers.The problem was intermittant until now.Now I've lost the afore mentioned controls.When ever the steering column was raised or lowered or the column was bumped into by a knee, thecar would either stall or lose those system funtionalities. Ive started to remove the steering column upper and lower covers but to no avail.I can remove the top piece only.The bottom piece will not let go even after all of the screws have been removed.No amount of gentle prying and manipulation can free the lower cover. It's frustrating to have something so simple to repair be held up by something so rediculous. Anyone know what may be holding this piece up? Any help would be greatly appreciated.
 

·
Registered
Joined
·
554 Posts
On the mk4 models there are 2 screws under the steering wheel I think your 07 should be the same. Turn the steering wheel and you should be able to access them.If youv'e already got those then you just need to apply a little more force.
 

·
Registered
Joined
·
12,099 Posts
Maybe, this diy; would help?

http://newbeetle.org/forums/technical-how/59181-ignition-switch-replacement-diy.html

I'm pretty sure; this should apply, to the later models. Pay particular attention; to melting terminal ends and the plug itself. I ended up having to replace the plug, switch and a number of terminal ends from being melted. They sell all the parts at your VW dealer or you can get a aftermarket plugs/pigtail with all the terminal ends, already installed in the plug.

For parts; always confirm, by your VIN # but I think this is a good VW part #.

ignition switch plug: 4A0 971 975

https://www.google.com/search?q=4A0+971+975&oq=4A0+971+975&aqs=chrome..69i57j69i61l3&sourceid=chrome&ie=UTF-8
 
1 - 3 of 3 Posts
Top