NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all, wife has a 2010 convertible beetle that is not going past 3rd.
1st, 2nd and 3rd work good no bumps. 4th, 5th and 6th wont engage.
I got a new valve body with new solenoids, replaced everything, new fluid in, reset all adaptations, exact same symptom :(
Found a totaled bettle at an auction near me. Its a 2007.

I already bought the car before I knew the transmissions have different codes.
Both cars are 2.5L with 6AT.
My 2010 is KGR code and the donor 2007 car is HTU.

Can I still replace the transmissions even thought they are different code?

Thanks all!
 

·
5/23/10 <3
Joined
·
11,009 Posts
First things first, have you scanned the car for transmission related codes with something like VCDS? I wonder if the car is in limp mode from another issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3 (Edited)
Yes, I checked car with VCDS and no errors. Car is not in limp mode, unless I keep trying to drive it in 4th gear.
If I drive it in tiptronic mode, I can select all the gears no problem, but 4th, 5th & 6th just feels like it has no traction. Almost like a heavy slip.
I did some research I found out K2 clutch controls this 3 gears. I ordered a pressure gauge that handles higher pressure and was going to test the pressure on K2 tap. But this beetle showed up at the auction for the same price as the gauges 😂.
I just received the gauges and maybe I will test K2 pressure before doing the replacement.


I have my car and donor car ready for the surgery. I just would like to be reassured it will work, maybe.

thanks for the reply.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Update:
Before pulling out the transmission, I tried replacing both TCM. Still got same symptom on my wife’s 2010.
The 2007 donor still drove good with the 2010 module. I decided to go ahead and do the swap.

Donor transmission is out. Took me about 6 hours to pull out the transmission.
Tomorrow is the day to pull out the 2010(KGR) transmission and install the 2007 (HTU).
249673
249674
249672
 

·
Registered
Joined
·
17 Posts
Update:
Before pulling out the transmission, I tried replacing both TCM. Still got same symptom on my wife’s 2010.
The 2007 donor still drove good with the 2010 module. I decided to go ahead and do the swap.

Donor transmission is out. Took me about 6 hours to pull out the transmission.
Tomorrow is the day to pull out the 2010(KGR) transmission and install the 2007 (HTU).
View attachment 249673 View attachment 249674 View attachment 249672
Update:
Before pulling out the transmission, I tried replacing both TCM. Still got same symptom on my wife’s 2010.
The 2007 donor still drove good with the 2010 module. I decided to go ahead and do the swap.

Donor transmission is out. Took me about 6 hours to pull out the transmission.
Tomorrow is the day to pull out the 2010(KGR) transmission and install the 2007 (HTU).
View attachment 249673 View attachment 249674 View attachment 249672
looking forward to hearing how this all worked out!
 
1 - 6 of 6 Posts
Top