NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Okay so I am repairing my new beetle 2001 myself. The left door had some problems and I fixed it. It now works great. One problem is the right door. The right door status is:

Speaker does not work (it's not broken, it just has no electricity) - it used to before I fix the left door... What went wrong?
The red light does not work (not broken either - no electricity) - it was like this since I bought it used
The window switch works
The lock switch works but locks only the left door

So even if I did something in the left door it is not the cause of all the problems since only the right speaker stopped working after fixing the left door, the other things were like this even before.

That's it. Few more notices... Since the remote does not work I manually unlock the car. So when I put the key in the driver side only that door opens. But when I put it in the passenger side both doors open. When I press the unlock button on the driver side it unlocks only the driver side. When i press that button on the passenger side, only the DRIVER side unlocks. When I change the mirror position from the switch in the driver side only the left mirror works the right one does not. When I press the button above the unlock button in either doors it does nothing.

I doubt one of the following...
The ccm has some problems - if so how can it be fixed?
The right door has no electricity mostly (since the only thing working there is the window switch) - if so how can it be fixed?
:confused:
 

·
Registered
Joined
·
2,231 Posts
I checked the wiring diagram and there is no connection between the left and right door speakers other than through the radio itself. Which of your speakers are currently working?

It sounds like the door module in the left door is not communicating with the central comfort module. These modules control the door locks, windows and mirrors. The problem is usually either the wiring inside the boot passing between the door and the door frame or the module in the driver's door. The module is part of the power window motor.
 

·
Registered
Joined
·
3,690 Posts
Speaker is not likely related, you may have just noticed the issue once you figured out you had other problems with the passenger door and looked at things in more detail??

Make sure the speaker does not look like this below!
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I checked the wiring diagram and there is no connection between the left and right door speakers other than through the radio itself. Which of your speakers are currently working?

It sounds like the door module in the left door is not communicating with the central comfort module. These modules control the door locks, windows and mirrors. The problem is usually either the wiring inside the boot passing between the door and the door frame or the module in the driver's door. The module is part of the power window motor.
All speakers work except for passenger door speaker.
The door locks work, except for when I press on the lock button inside the door.. In that case only the driver lock works. Windows all work. Left mirror works. Passenger mirror does not.
Are you sure the problem is in the left door cause it sounds like the problem is in the passenger door. I'll try to check the door module in both doors if I can reach them.

And about the passenger speaker I am certain that it used to work.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
And I forgot to mention, although the light indicator in the radio works, the alarm ( or theft ) system does not work. I mean the alarm never goes off even if someone tried to go into the car.
 

·
Registered
Joined
·
3,690 Posts
As I recall the Comfort Control Module happens to be in the drivers door motor controller??

If you had a wiring connector on the driver door motor module not fully seated, this could be the source of your problem as well??

As of the alarm not working, likely due to the alarm not fully setting as it thinks the passenger door was never closed?

Not sure if these problems all started at the same time out of nowhere.

If I was in your situation, I would likely check all your fuses, then disconnect the battery for at least 30 minutes and see if it clears anything up.

If not, then I would likely check the connectors on the drivers window module if they have been recently disconnected to make sure they are fully seated.
 
1 - 6 of 6 Posts
Top