NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
This is my first post after viewing these forums constantly, so here goes.

I have a 2004 NB GLS with built in seat warmers. The first few months after I bought my car they worked great. Now the passenger side works consistently but the drivers side only works periodically. The fuse is fine, that I have checked, but I haven't done much else as far as troubleshooting.

The dealership is always lazy when it comes to fixing things like that, so I guess I have to do it myself.

I read of someone else having the same issue with a Jetta, and they pulled back the upholstery to find a loose wire. How do I take the upholstery off of the drivers side?

How would I check if it's the switch?

Any help would be appreciated.
 

·
Registered
Joined
·
950 Posts
Sounds like my seats, the driver side only works if I push to the right as I'm turning the dial.

Getting the carpet up... you have to pull the seats, center console and trim panels on the inside of the car. It's not easy.

But you wouldn't do that first. First you would just test the wires from switch to harness on the seat to determine if there was a wire fault.
 

·
Registered
Joined
·
2,231 Posts
There is a green 6-pin connector under the seat. Disconnect it and measure the voltage on pins 3 and 4 on the wire harness side of the connection. If you don't see voltage with the key on, try with the engine running. If the switch is good you should get battery voltage with the switch set above 0.
 
1 - 3 of 3 Posts
Top