VW Beetle Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter · #1 ·
Hello. So I was driving my beetle the other day and I noticed that when I pressed On the gas the car wasnt going. It will go but very slowly. the check engine light has not came on. I've had this problem before and I changed the speed sensor. The cel came on that time and it gave me a code. Changed the speed sensor and everything was fine. Idk Wat to do now. Should I get the transmission fluid changed ?? Any info will help.
 

·
Registered
Joined
·
15,842 Posts
Well, there could be a number of problems; for a poor running engine. I would scan the car for trouble codes; how many miles on the car and when was the last time you had a tune up done (e.g: plugs, wires, fuel/air filter, etc)?


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #3 ·
So it has about 139000 miles. The spark plugs were changed about 3 months ago. It's gonna need a oil change in. About a lo th or so. Air filter was charged about 4 months ago. That's pretty much it. The check engine light hasn't came on. But I will check later mayb their could b some pending
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #5 ·
Unfortunately it says page not found. But I was reading that supposedly the transmission fluid is a lifetime never change fluid lol. But I doubt. So should o go forward with changing the transmission fluid ??
 

·
5/23/10 <3
Joined
·
11,417 Posts
I'd change it. No need to flush, just drain the fluid and put in a new filter.
 
1 - 7 of 7 Posts
Top