NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I posted this a bit ago but with a more confusing title as I didn't have anything narrowed down:

My ABS, BRAKE, ENGINE Lights were all on.

I changed my 5A fuse (ABS) and messed around to figure out what was blowing it. Heres the Before and after of changing the fuse.

BEFORE:
- AC not blowing cold air
- ABS light on
- E-Brake light & alarm on
- Engine light on with code reading a problem with ABS
- ASR light on


After:
- ALL lights off
- AC blowing cold-ish (colder than was before) air. (ac still has to get fixed on another issue)
-car working fine


I looked it up and saw that some people with beetles had their climate control wiring messed up (under the radio), But, as i look at mine all seem to be in the right place.

Now, i found out what blows the fuse. Everytime i switch to the Side Mirrors Defrost !!!
The windshield defrost button works fine and doesn't blow anything, but when i touch the button on the door for the side mirrors defrost setting, the fuse blows!

Where should I go from here?
 

·
Registered
Joined
·
2,172 Posts
Is your side mirror switch the original one? An incorrect replacement part may possibly cause this problem.

Other than that, two wires are shorted somewhere or there is broken grounding connection.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Is your side mirror switch the original one? An incorrect replacement part may possibly cause this problem.

Other than that, two wires are shorted somewhere or there is broken grounding connection.
I have no idea. the guy I bought it from didn't tell me about the issue and never told me if he changed the part or not.

where should I look for the short? in the door panel or where it connects in the car?

thanks!
 
1 - 3 of 3 Posts
Top