VW Beetle Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've just recently had a 2nd hand 04 beetle (Pink :> hence the name!) everything was fine until I started going on the national speed limit roads. As I'd hit about 65, the check engine light would come on and it would break for a split second then drive as normal, however after that the acceleration would be incredibly slow.

I took it back to the garage who fixed the problem and other minor things (windscreen wipers, etc.) then took it back on the NSL roads for a quick test. First off it accelerates brilliantly, until I slow down for a roundabout then accelerate again. At this point the acceleration is really slow again.

I know there is an electric system that regulates the road conditions and heat of the engine so it can adapt accordingly to avoid damage or crashes, but I wanted to know if this was normal?

Basically I want to know:
After going over 50+ speeds, then breaking to a stop or almost stop, is it normal for acceleration rate to slow down dramatically?

Please help and thank you!
 

·
Premium Member
Joined
·
5,028 Posts
I know there is an electric system that regulates the road conditions and heat of the engine so it can adapt accordingly to avoid damage or crashes, but I wanted to know if this was normal?
The only thing that controls the engine heat is the thermostat, these engines aren't that complex. :)

Have you changed the fuel filter lately? How many miles on the engine? You might have a clogged IP. The IQ level might be set wrong, could be lots of things.
 
1 - 2 of 2 Posts
Top