NewBeetle.org Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
I got it day before yesterday. 63k on the clock. I hoped it would not need work, but the airbag lite is on. Pulled codes with an Autel, it's a short in the driver's side seatbelt. Airbag lite on usually indicated the system is disabled, so I'll fix that pretty quickly.

While it was hooked up, I pulled the codes, it's showing P1128. Lean off idle bank 1. Research indicates probably a poorly functioning MAP sensor or vacuum leaks in the hoses. Got lots of new hose around here, try that first and clean the sensor. After I figure out how to get to it. Probably it will improve throttle response, too, I hope.

Was hoping the low mileage would mean no faults. :oops: I need to smog it in 6 months.
 

·
5/23/10 <3
Joined
·
10,997 Posts
What year is the car? Miles matter, but time can almost be more of a concern on some items.
 

·
5/23/10 <3
Joined
·
10,997 Posts
If you don't have a record of it being done, I would get the timing belt and water pump changed out ASAP.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #7
I have a record of it having been done. But thanks.

Researched the thing with the airbag lite, short in the driver's seat belt. I ordered a new seatbelt latch, seat belt goes into it, yesterday. Relatively easy fix, and a chronic problem on older NB's. Should have been a recall, but there wasn't.

Thanks for your help, Smileybug.
 

·
Registered
Joined
·
1 Posts
B in T, Could you please post the part number, source and cost of the seat belt latch assy? I have to get one for my wife's 2004 Turbo Conv.
thanks, tr
 
1 - 10 of 10 Posts
Top