VW Beetle Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 · (Edited)
Is anyone familiar with this? It happens only when driving. Not on stop. If I press the brake, even before it reaches the point where it slows the car, and release it. There is a little noise and the car shakes.
 

·
Registered
Joined
·
15,839 Posts
A common problem; is the brake booster hose, it connects to the brake booster and the hose cracks, causes idling problems and reduced brake performance. These get brittle over the years; the engine vibrates and flexes the hose, the hose cracks and causes a vacuum leak. Many times; you can use electrical tape and hose clamp, as a temporary fix; until you get a new one.

Here are some different types; depending on the engine and year.

https://www.google.com/webhp?source...ooster+hose&tbm=shop&spd=17240419821934928389
 

·
Registered
Joined
·
15,839 Posts
I appreciate your frustration; however, after 14 years, parts are going to wear out and break. Pull off your brake booster hose and see if it is cracked, tape it and put a hose clamp on it, as a temporary fix. This may not be the problem you are having but it is worth a check.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #5 ·
Yes, a mechanic should come tomorrow to inspect everything. I have just looked at my Twingo manual and it also has a brake booster. I just didn't know about it because it never had a problem.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #6 ·
Thw mechanic found out the problem to be in the sway bar link ends that need to be replaced.
 
1 - 6 of 6 Posts
Top