NewBeetle.org Forums banner

1 - 12 of 12 Posts

·
Silverpodgirl
Joined
·
95 Posts
Discussion Starter #1
This started a couple of months ago. All of a sudden the check engine light came on. I read several horror stories about this and the dealer etc. I did notice a pattern which seems to be connected to putting gas in the POD. It is NOT the gas cap, but there is something (black plastic "thingy") I can see when I remove the gas cap. Whatever this thingy is seems to not always reseed itself properly when I gas up. If I mess around with it and push it in the light does go off eventually after it cycles etc. What is that thing and what is going on.

Thanks

Oh yeah....2001 GLS 5 speed
 

·
Super Moderator
Joined
·
14,714 Posts
My CEL is on, and has been on for over a month now. I know what the problem is.

Upon getting fuel one day, I got my receipt, said thank you, turned the key, and ~bing~ on comes the light. Since we have no self-service here, I figured the gas guy didn't tighten the cap, which has happened before. So, I didn't worry too much about it. When the light continued, even after tightening the cap, I finally took it in.

It has to do with the fuel alright. I have a clogged fuel line, probably caused by additives in cheap fuel. I was told which gas was the worst, (I used both), and which were the best. Then I was told $338 to fix, or use this fuel line cleaner, and try to remedy yourself. We used both cans of this stuff, right before two fill-ups. Light is still on. But car runs fine. Oh well.


Good luck to you. The problem is likely minor.
 

·
Premium Member
Joined
·
11,013 Posts
dnyed said:
My CEL is on, and has been on for over a month now. I know what the problem is.

Upon getting fuel one day, I got my receipt, said thank you, turned the key, and ~bing~ on comes the light. Since we have no self-service here, I figured the gas guy didn't tighten the cap, which has happened before. So, I didn't worry too much about it. When the light continued, even after tightening the cap, I finally took it in.

It has to do with the fuel alright. I have a clogged fuel line, probably caused by additives in cheap fuel. I was told which gas was the worst, (I used both), and which were the best. Then I was told $338 to fix, or use this fuel line cleaner, and try to remedy yourself. We used both cans of this stuff, right before two fill-ups. Light is still on. But car runs fine. Oh well.


Good luck to you. The problem is likely minor.
Which gas was the worst and which was the best?Pm me if needed.
 

·
Super Moderator
Joined
·
14,714 Posts
According to the service department, mind you: ;)


Worst:
Texaco
Arco

Best:
Union 76
Chevron
 

·
Premium Member
Joined
·
11,013 Posts
I usually gas up at shell or bp. I was in Albany Il. and used the local station (only one in town) and after that my problems started. I will NOT go there again!!!
 

·
Silverpodgirl
Joined
·
95 Posts
Discussion Starter #11
Cel

Even tho the light has been off for awhile I am going to try the fuel line cleaner/additive. Figure it can't hurt. I have almost 68,000 miles on it (got it new) and I have never added any before. Usually the light stays off just long enough to fool me into thinking it will never come back on and then...

I still think it has something to do with the "thingy" in the tank that I can see when I gas up. If I mess with it, it does make the light go out eventually after it does its cycling thing. Usually goes on 2-3 days after I gas up, so it is definitley connected to gasing up.
 
1 - 12 of 12 Posts
Top