VW Beetle Forum banner

1 - 4 of 4 Posts

Registered
Joined
17 Posts
Discussion Starter · #1 ·
So I have a 2003 2.0 convertible. I pulled up to a stop sign went to go and it suddenly wasn't moving anywhere. No wierd loud noises or thunks or anything. Just suddenly wasn't moving.Well I put it in park and learned every gear is neutral now.Its starts up fine and runs fine but it only does neutral now.Ths TCM light on my dash is on as well as the check engine(but honestly that's like always on so馃し馃槀) It was occasionally having issues with not downshifting or upshifting at what I thought to be an appropriate time as well before this happened but I figured. I know TCM issues aren't looking to be super common but I'm not sure what else it would be?
 

5/23/10 <3
Joined
11,299 Posts
You need to scan the car for codes to start with. Also, have you checked your axles to make sure they are in tact?
 

Registered
Joined
17 Posts
Discussion Starter · #3 ·
You need to scan the car for codes to start with. Also, have you checked your axles to make sure they are in tact?
Okay I think my dad has a scanner I'll have to borrow and try to get codes tonight. I have not but I just redid my struts.in the summer and had that all tore apart and they were both good then and I've.not had any like clunking or thunking moises but I will check them to make sure!
 

Registered
Joined
53 Posts
Take it somewhere else. I've never heard a whining noise be because of the TCM. I'm not saying problems can't be the TCM sometimes, but a lot of time the "it needs a TCM/ECM" is the "I don't know what's wrong with it" Kodi nox diagnosis.
 
1 - 4 of 4 Posts
Top