NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I was driving my New Beetle and making a turn, and when I activiated the turn signal, the turn signal indicator didn't go on at all, the same with the other turn signal : Both turn signals, left and right, simply won't turn on.

I also tried the flashers/hazard lights : Whenever I press the red triangle, it goes blank, and it doesn't work, (the red triangle shuts off completely, no light.)

When I parked the car, and turned it back on again, the left turn signal and the hazards worked. When I tried the right turn signal, it didn't work, nor the hazard/flasher. I tried the left turn signal again, this time it also didn't work.

What could this be, is this fixable?
 

·
Registered
Joined
·
13,423 Posts
A common issue, is failure of the hazard/flasher relay; it is integrated into the emergency switch, depending on the year is on the dash or under the hvac controller or stereo. Sometimes, they can be revived; using some contact cleaner but in my case, I had to replace mine, to finally fix the issue.

This is the cleaner; that i use:

CRC 05103 QD Electronic Cleaner -11 Wt Oz



Here in the USA, this product; is sold at all auto parts stores, hardware, home improvement stores but the best price is @ Walmart, in the auto supply area ($7-$10 at most stores and under $5 at Walmart).
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
A common issue, is failure of the hazard/flasher relay; it is integrated into the emergency switch, depending on the year is on the dash or under the hvac controller or stereo. Sometimes, they can be revived; using some contact cleaner but in my case, I had to replace mine, to finally fix the issue.

This is the cleaner; that i use:

CRC 05103 QD Electronic Cleaner -11 Wt Oz



Here in the USA, this product; is sold at all auto parts stores, hardware, home improvement stores but the best price is @ Walmart, in the auto supply area ($7-$10 at most stores and under $5 at Walmart).

Hi billymade,

Thanks for the helpful info, this looks to be the issue. I tried adjusting the hazard switch making sure it was secure tightly and the indicators/hazards turned back on. I will try the contact cleaner, but if I want to change the actual switch, should I be using special tools to remove it ? It seems pretty secure but do I need to disconnect it first if I want to remove it and put in the new one?
 

·
Registered
Joined
·
59 Posts
Discussion Starter #5
Hi billymade,

The flasher relay looks to be below the HVAC controls (right under the three dials) 2001 model year, so definitely not in the dash. Is it possible to remove the switch and replace it?
 

·
Registered
Joined
·
13,423 Posts
1 - 6 of 6 Posts
Top