NewBeetle.org Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
It's me again, Mark in Tampabay. 5th day of owning a NB and Im not sure I did the right thing. Please convince me otherwise. I am trying to figure out, with no avail, what the 3 fuses (under the hood, on top of the battery) control. I have searched every internet, Haynes/Chiltons, owners manual, etc. The one to the far left (passenger side) was missing and looked a little burned in the slot, and my airbag light is on. I re-fused it and no changes anywhere. The chimes dont seem to work for the key/lights/door etc either. I guess that may have been disconnected, and if so, where do I reconnect it? Thanks for the advice and, rest assured, I will have more questions.
 

·
Premium Member
Joined
·
4,753 Posts
These are a typical issue with the NB. Frequently go into "melt down" mode, and require replacement. From memory the box contains (5) fusible links and (3) fuses ( I am on the road and don't have my Bentley with me). As I also remember, one each is involved in the a/c system circuitry. I believe all are used in all years and models. Forget using everything but a Bentley for information and repairs. Someone will be along with more help, I'm sure.

A little thread searching will also offer a wealth of info about this little item. Here is another Orger with a similar thread running right now
http://newbeetle.org/forums/questions-issues-concerns-problems-new-beetle/51649-blown-fuse.html

MORAV
 
1 - 2 of 2 Posts
Top