NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
There is a vacuum leak at this area that I am trying to track down. I took the electrical connector and the hose off to better see what was here. If I spray cleaner near the clamp that holds the hose to the oil filler, I get a huge jump in idle speed. What is the sensor that is here? Do I need to replace the whole assembly from the MAF to the Throttle body? I believe this is the Engine Air Intake Hose 1C0-129-684, How do I determine if I have the Cold Weather Package? This was discovered trying to fix a P0506 idle air control CEL.
20190831_154505.jpg
 

·
Registered
Joined
·
11,211 Posts

As to identifying the exact part # for the intake hose; there typically is a part # on the part somewhere; the "cold weather package", typically adds a heating element somewhere, it looks like you have a plug undone that might be it (reduce moisture or de-icing capability; make starting easier)? Searching for parts by your vin # at your local vw dealer or on vw's parts site may help?

www.parts.vw.com


A more sophisticated testing procedure; could be a smoke test?

What year, engine and trans does your new beetle have?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
1999, AEG 2 Liter with auto transmission. The plus was disconnected to get a better view of the part..
 

·
Registered
Joined
·
11,211 Posts
1 - 6 of 6 Posts
About this Discussion
5 Replies
2 Participants
GriffingRA
NewBeetle.org Forums
The New Beetle forum, come in and join our discussions on the new Volkswagen Beetle. Talk about modifications, performance and color choices.
Full Forum Listing
Top