NewBeetle.org Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi all!

Recenlty, about a week ago my check engine light went on..
I havent noticed any changes.. the car drives as before.

Today I have checked the car with the Vag-Com and got the following codes:
P1103, P1116 - Lambda sensor problems (low popwer, connection break) - I have already order it..:confused:

and third which worries me the most P1200 - Turbocharger valve mechanical problem..:mad:

have u got any experience with them?

Thx
 

·
Registered
Joined
·
30 Posts
Discussion Starter #2
turbo photos..

I have add some photos of the charger.. not very visible but something.. can anybody see if it is a stock turbo and which is it? oh and can there be a connection between the lambda and the turbo??
 

Attachments

·
Premium Member
Joined
·
580 Posts
the lambda could be an o2 sensor, but the other may just be as simple as a vacuum leak on the waste gate.
 

·
Bourgeoisie
Joined
·
309 Posts
Turbocharger valve mechanical can also (and more often) mean the diverter valve, which is easily and cheaply replaceable.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #5
p1200

After changing the O2 sensor the light is off.. also the code regarding the turbocharger disappeared.. Could the have been connected? :rolleyes:
 

·
Registered
Joined
·
5,793 Posts
possible, I don't know why; it doesn't seem likely really... but it's possible. If it stays gone, good. If it comes back, you might want to check the vac lines and change the DV.

That turbo looks stock, can't see the plate to tell you specificly what # it is, but it should be a Borg-Warner K03S.

Simliar to this.



man oh man does that inlet look teensy
 
1 - 7 of 7 Posts
Top