VW Beetle Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I think my VSS (vehicle speed sensor) is toast. I have used the "search" function extensively on several forums. All similar issues seem to be eventually dealt with by a professional mechanic or never clearly resolved. I'll make sure to post my solution this problem (with pics I hope!) whether I succeed or fail.:cool:

I've had the car scanned at AutoZone and I have seven codes in all. The most troubling were "Output Speed Sensor" and "Incorrect Gear Ratio" the rest were misfire/ignition codes. The car is currently in "limp home mode". When the CEL came on, I was delivering pizza and driving too fast...:eek:

I think that the VSS could be faulty and causing all codes. I believe the "Improper Gear Ratio" is due to no input from the VSS. I understand that misfires are determined using output from the VSS. See where I'm going with this?

Has anyone replaced their VSS? Am I on the right track?
 

·
Registered
Joined
·
5,793 Posts
Maybe. It's a cheap part worth a try at replacing it. You can do so from underneath w/no serious disassembly.

The VSS is a plastic gear that drops down into the transmission from the top. It's very possible it's just gotten messed up and isn't reporting properly.

I think you'd be able to take it out and see if it looks okay or not... this one was broken upon transmission removal. but it should all come out as 1 piece.
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 · (Edited)
Thanks for the input. At least now I know what I'm looking for.

I ordered a Bentley manual today and selected next day air. The Haynes manual that I bought at AutoZone isn't very good; It doesn't really specify how to access the sensor. From the bottom, I cant really see anything. From the top, everything looks buried under the intake manifold.

**EDIT**
I found the sensor listed in my Haynes manual, but it's not the one I'm looking for. I think the sensor that I found is listed in this photo as G22. Based on your photo above and the part I bought from AutoZone, I think maybe I need to find G38?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Ok... I'm pretty sure I found it this time. Behind the motor, on top of the transmission, in a foil bag...right? Now I just gotta figure out how to remove the connector without looking at it.
 

·
Registered
Joined
·
5,793 Posts
Yep, in the foil bag, that's the one. 2 snaps on the bag. The connector is like all those other D connectors. All plastic, plastic arm that rotates up and off the clip.

NOT the same style as G68.

Man, those 01M's look different from my 02J.
 
1 - 5 of 5 Posts
Top