NewBeetle.org Forums banner

1 - 6 of 6 Posts

·
Vinnlasvegas
Joined
·
3 Posts
Discussion Starter #1
So heres my problem. When i am idling my a/c isnt working, but once i start driving over 30 mph it kicks in and starts blowing really really cold. Then when i get back to the light, it starts with hot air again. I live in vegas, so i need my a/c and im sick of turning it off at every stoplight. Is this the compressor going bad or something else? I just replaced the water pump on my 2000 Beetle, at 35,000 miles...i dont know why it blew out so early...plastic impeller i assume. Anyways, heres my other problem, the other day i replaced the fuse to the outside temp sensor and clock, when i turned the car back on, The airbag light was on! i didnt move the seat or anything so i dont think a wire was cut. is there a fuse, or do i just have to reset it with the VAG-COM? I really dont want to pay 105 dollars for them to tell me nothing is wrong or make up a reason to fix something. Also, the other day, the three climate control knobs...(Hot/Cold, 1..2..3..4.., and the Direction of air flow), stopped lighting up? is there a fuse for that too??? Please help me! my car is going crazy on me. :confused:
 

·
Banned
Joined
·
1,258 Posts
So heres my problem. When i am idling my a/c isnt working, but once i start driving over 30 mph it kicks in and starts blowing really really cold. Then when i get back to the light, it starts with hot air again. I live in vegas, so i need my a/c and im sick of turning it off at every stoplight. Is this the compressor going bad or something else?
YES! Mine just went a month or so ago. It's the compressor. Do you ever hear a ticking noise sometimes? Kind of sounds like a baseball card in bike spokes, only louder.
 

·
Vinnlasvegas
Joined
·
3 Posts
Discussion Starter #3
Yea, its not too loud though. but there is a ticking, especially if i accellerate slowly. How much was the compressor
 

·
Banned
Joined
·
1,258 Posts
LOL! Not sure how much it costs yet. Haven't had it fixed. The place I went to here in Jax said it would cost about 1300.00 (but that's always subject to change) to replace (parts and labor). It's not just the compressor that get's changed out, they have to replace the expansion valves and what nots too. They also have to flush my system out since the ticking was metal going all over the place in side the AC system.
 

·
Registered
Joined
·
3 Posts
You know, I had the exact same problem with my a/c - it would only work when I had the rpm's up to about 2500 or more. In addition, my cruise control did not work. The airbag light was not on though. The problem turned out to be a bad cable going to the fuse relay directly on top of the battery. Turns out that battery corrosion had eaten through the insulation and then through the wire! They replaced the relay (at a cost of about $100).
I would check that cable first - on my 2000 NB, it's red and goes directly from the battery terminal to the fuse relay on top of the battery.
 

·
Vinnlasvegas
Joined
·
3 Posts
Discussion Starter #6
U know, my cruise control doent work either! im gonna check my car tommorrow and take a look at the cable and see if it looks strange and ill let you know!
 
1 - 6 of 6 Posts
Top