NewBeetle.org Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi

I have a new 2013 Beetle 1.2 TSI manual (I'm in the UK) and everything is working fine apart from the clock. When the car moves, the clock disappears and is replaced with a KPH reading. I've spoken with VW about this and initially they told me that law states I have to have MPH and KPH showing in case i want to drive abroad. Fine, or so I thought. Anyway, my MPH indicator also shows KPH aswell on the manual dial so theres no need to show KPH separately. I queried this with VW aagain and asked them how I'm supposed to tell the time when driving, they told me to look at my watch......... I'm not impressed! Anyway, my car is currently back with VW and with all other models they've checked, this problem does not occur. They've told me it may need a new dash pod (?) which has to be shipped from Germany....., could take weeks. Can anyone help or has anyone else had this problem - it's driving me insane!:confused::confused::confused::confused:
 

·
Registered
Joined
·
41 Posts
Wow that does sound annoying! I can't really help other than to say don't accept their excuses. It's a brand new car and should have come to you in perfect working order. Good luck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you. I'm giving them 2 more weeks (i picked up the car on the 22nd March!) and if it's not fixed them I'm going to demand they replace it with a brand new one - it's getting beyond a joke now. With extras I paid just short of £20k for the car and it's unacceptable! I'm so annoyed!
 

·
Premium Member
Joined
·
3,454 Posts
Have you tried toggling the display? The button on the end of the wiper arm on mine moves the info to a different style display. Not sure if there is a big difference in US and your version.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thank you :)

Yes, I've tried toggling the display and that doesn't work. The car was back with VW yesterday and they still can't work it out, they're currently waiting for a new dash pod to be shipped from Germany - could take weeks!

The problem they have is that I have the only Beetle in the country of that particualr model so they can't test it against another one. There are other new Beetle around but not with my particular spec, it's so annoying.

And so the saga continues.........:mad:
 
1 - 8 of 8 Posts
Top