NewBeetle.org Forums banner

1 - 10 of 10 Posts

·
adittz
Joined
·
33 Posts
Discussion Starter #1
so i was driving yesterday and everything was fine (it snowed here... if that means anything?) and then out of nowhere, i went to turn and i put on my blinker... and nothing. the stem moved like to flip up or down, but nothing blinked inside or outside. my hazards don't work either.

WHAT IS WRONG WITH MY BUG?!?!?!?!?
 

·
Premium Member
Joined
·
4,753 Posts
Your turn signal relay may have taken a poop, may or may not have been triggered by the cold temperature. It's also possible you have lost the ground connection for the turn signal relay/emergency flasher switch/emergency flasher warning light assembly

More here -
http://newbeetle.org/forums/2-0-liter-gas/52352-signal-lights-stopped-working.html

Here's the DIY (poster says $30 for the part)-
http://newbeetle.org/forums/technical-how/5460-how-hazard-relay-replacement-turn-signals-hazards-not-working.html

MORAV
 

·
adittz
Joined
·
33 Posts
Discussion Starter #3
thanks! the sun is out today so maybe it'll warm up and work? lol it was at its coldest when they stopped so i'm keeping my fingers crossed.
 

·
Premium Member
Joined
·
4,753 Posts
thanks! the sun is out today so maybe it'll warm up and work? lol it was at its coldest when they stopped so i'm keeping my fingers crossed.
Broken things don't fix themselves; if they do start working, expect it to be momentary. Of course then, maybe the worst weather is over up there for another year. I'd save the thread, you're going to need it.
 

·
adittz
Joined
·
33 Posts
Discussion Starter #5
i didn't expect it to fix itself. but i've had a lot of things like that happen in all of the time i've spent driving cars, so it wouldn't be too far fetched if it did.

i guess from now on i'll just go to the vortex with all of my questions. whenever i ask anyone something on here i feel like my questions are unwelcomed.
 

·
Premium Member
Joined
·
4,753 Posts
i didn't expect it to fix itself. but i've had a lot of things like that happen in all of the time i've spent driving cars, so it wouldn't be too far fetched if it did.

i guess from now on i'll just go to the vortex with all of my questions. whenever i ask anyone something on here i feel like my questions are unwelcomed.
Really sorry, didn't mean to make you feel that way, or offend you. I guess I should have added an (lol) in that last post. Most around here, know how willing to help I am, but that I also have a dry wit.

I made a real effort to help you out, doing the thread searching, and posting up for you. I work to be accurate and afford as much information and back-up as I can quickly find. I don't see THAT at all on the Vortex, and here you had an answer in what, less than an hour and a half. The Vortex, it might have been a couple days in the NB Forum (we're somewhat outcasts over there), if ever. I just see a lot of posts where people expect their problems to just go away, like when they kill the CEL, hoping that that solves their problem, or worse, ignore it for years figuring it's no big deal since their car is running "fine".

M. :)
 

·
Registered
Joined
·
950 Posts
Had this happen with my bug a few years ago, had to replace the emergency warning light switch in the console. I guess if it goes, the whole turning light system goes.
 

·
Premium Member
Joined
·
4,753 Posts
Had this happen with my bug a few years ago, had to replace the emergency warning light switch in the console. I guess if it goes, the whole turning light system goes.
Because the flasher relay is built into the switch assembly. ;)
 
1 - 10 of 10 Posts
Top