NewBeetle.org Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, my 1999 GLS window regulator cable broke and of course, the regulator sucked in all the cable and bound it all up. I got the regulator replacement kit this weekend and installed it. It was a bit of a pain but it went in fine with some work. The new sliders are actually quite a bit nicer than the originals..

Anyhoo, here's the problem I'm having. When I roll the regulator up/down without the window attached, it moves just fine and works great. Unfortunately, when I attach the window into the clamps, it goes part way up or down and catches, then won't go any further. I think it's getting friction somewhere that is causing the pinch guard to stop the motor.

I took out the window scraper (until I could get on here and figure out what to do). and it worked better for a day or so due to the decreased friction on the window but today it went bad again and almost stranded me with an open window. Luckily I got it closed and now I'm not messing with it.

Has anyone had this problem when replacing the regulator? Is it a sign that the motor needs replaced too? I do hear some strange cable grinding sound but I can't tell if it's the motor. I do think it's strange how well it moves the sliders up and down until the window is attached.


Could it be an issue with aligning the window? If so, any suggestions?

I appreciate ANY help you can give. I love this car but it's suddenly getting very frustrating.

Thanks,
Scott
 

·
Registered
Joined
·
142 Posts
could try to lubricate the rubber channel on each end of the window where it slides in, what I've done is put the window all the way down, use a can of lubricant and the red straw attachment, spray inbetween edge of window and rubber at the back side and do the same to the front, spray as much lubricant along the track as you can reach, then move the window up and down, this may help
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks, Now I need Window Motor!

Thanks, tried the lubrication but then the motor wouldn't even try to lift the glass back up. I pulled the glass out of the brackets and the motor isn't even trying to move the regulator anymore, so I guess it's time for a new motor..

Do you have any recommendations on where to find a motor? I see used ones for as low as $35 but they always seem to be passenger side. Has anyone used an aftermarket one?
 
1 - 3 of 3 Posts
Top