VW Beetle Forum banner
1 - 8 of 8 Posts

·
Bug me again!
Joined
·
2,758 Posts
Discussion Starter · #1 · (Edited)
Changed the pre-cat O2 sensor a week ago. No hesitation since!
This has been bothering me for years!

 

·
Bug me again!
Joined
·
2,758 Posts
Discussion Starter · #3 · (Edited)
No worries, not speeding. Just happy not to be giving myself whiplash :D
I know I'm not the only one with this problem, so just trying to get the word out there about a possible solution :goodjob: :banana:
 

·
Bug me again!
Joined
·
2,758 Posts
Discussion Starter · #5 ·
There's a good DIY on the Vortex (not NB-specific, but the 2.0 Jetta instructions were spot-on).
Bought the sensor from a Canadian online place, $135. As the DIY describes, the old sensor can be hard to get out. The b/f used penetrating lubricant AND small butane torch (see safety disclaimers in the aforementioned DIY). It was a 1 hr job, and most of that time he spent getting the old sensor out.
I had a second reason for changing this sensor, my emissions were high in NO gas.
Of course, I can't guarantee it will solve your problem as well.
But there's a good chance I would have tried changing this sensor earlier, if there was a thread like this one on the Org already, instead of wondering what it was for 3 years.
 

·
Bug me again!
Joined
·
2,758 Posts
Discussion Starter · #7 ·
Well, what does it feel like?
 

·
50% OLD (o\_l_/o) School
Joined
·
1,432 Posts
Its only when I am moving off in 1st gear it (sometimes) jerks a little.... I think perhaps I am giving too much gas.. I am not sure...

Otherwise he runs like a charm. Sometimes I think he believes he is a turbo.
 
1 - 8 of 8 Posts
Top